PhotoActivity Forum
PhotoActivity Forum
Home | Profilo | Registrati | Topics attivi | Membri | Ricerca | FAQ | Informativa sui Cookies
Username:
Password:
Salva la Password
Hai dimenticato la tua Password?

 Tutti i Forums
 PhotoActivity
 Forum's digest
 Profilo Monitor Windows 7 e LUT scheda grafica
 Nuovo Topic  Topic Chiuso
 Visualizza per la stampa
Autore Topic Precedente Topic Prossimo Topic  

AlbertoM
Moderatore

Italy
4742 Posts

Postato - 16/11/2013 :  02:03:51  Mostra il Profilo  Visita la Homepage di AlbertoM
Salve a tutti

Questa mattina ho fatto un profilo monitor ad un portatile di un cliente, con spettrofotometro Eye-One PRO e i1 Profiler

E' andato tutto bene, però dopo il riavvio succede una cosa strana: il loader di X-Rite (presente nella cartella Esecuzione Automatica) carica correttamente la LUT della scheda grafica pescando le informazioni dal profilo ICC di sistema, però, dopo una decina di secondi, la LUT viene resettata da qualche applicazione, e quindi il monitor torna ad essere scalibrato

Lanciando di nuovo il loader manualmente la LUT viene ricaricata bene, e tutto continua a funzionare fino al successivo riavvio

Premetto che ho disabilitato la "Taratura Colore" di Windows, quindi credo di poter escludere che la colpa sia del S.O.

Penso che sia il SW della scheda grafica, che una volta caricato, resetta la LUT
Non ci sono opzioni in tale software per evitare quest'operazione

A qualcuno è capitato e ha risolto in qualche modo?

A me viene solo in mente di fare un .bat in cui mettere un ritardo di 15 secondi prima di lanciare il loader
Poi metterei tale file.bat nella cartella Esecuzione Automatica al posto del loader.exe

Però mi sembra un workaround non tanto elegante.....

BTW, sul mio WIN7 funziona correttamente....

AlbertoM

Michele Volpicella
Advanced Member

1450 Posts

Postato -  16/11/2013 :  18:06:57  Mostra il Profilo  Visita l'Homepage di Michele Volpicella
Ho avuto la stessa esperienza anch'io da un cliente :)
Lì su 3 monitor Lacié (collegati a 3 PC diversi) due caricano la LUT senza problemi e uno no.
E non lo fa nè con i1profiler, nè con Lacié Blue Eye e neppure con Basiccolor. Alla fine gli ho fatto il profilo con Basiccolor e l'ho istruito ogni mattina a cliccare sull'icona di Basiccolor: quando parte il programma si carica la LUT. Non è elegante, ma funziona.

E comunque non ho assolutamente capito perchè uno non vada e gli altri due sì, non ho controllato se le schede grafiche sono le stesse.



Stampatore Fine Art
www.slowprint.it
Go to Top of Page

rosario_ge
Advanced Member

Switzerland
882 Posts

Postato -  16/11/2013 :  20:07:37  Mostra il Profilo  Visita l'Homepage di rosario_ge
Premessa la mia scarsa attendibilità tecnica, avevo per pudore evitato di rispondere ma vedo che Michele ha avuto la stessa mia esperienza....
A me capita solo sul 2° monitor ; ogni volta che spengo il sistema, al riavvio non si 'carica' la calibrazione .
Win 7 con scheda Quadro K 2000 D .
Lo fa sia con i1 pro + profiler che con Squid3 + basiccolor.
Rimedio con la stessa manovra che ha descritto Michele...

------------
ro
Go to Top of Page

AlbertoM
Moderatore

Italy
4742 Posts

Postato -  17/11/2013 :  02:03:21  Mostra il Profilo  Visita l'Homepage di AlbertoM
Grazie a tutti

Allora, questo è il mio workaround, scaricare questo file, poi:

1) copiare il file sleep.exe nella cartella C:\Windows
2) fare click con il destro su CaricaLUT.bat poi --> Modifica

3) Ora occorre personalizzare alcuni parametri:

Il comando @set ritardo=15 mette in attesa il sistema per 15 secondi prima di caricare la LUT della scheda grafica
E' possibile modificare il valore in base alle proprie esigenze

Il programma che carica la LUT, nel caso di X-Rite i1 Profiler è:
C:\Program Files (x86)\X-Rite\i1Profiler\XRGamma.exe

Nel file CaricaLUT.bat questo percorso viene generato con le tre righe:

C:
cd Program Files (x86)\X-Rite\i1Profiler
XRGamma.exe

Se si utilizza un altro programma per caricare la LUT, occorre modificare quelle 3 righe con il percorso corretto

4) fare click con il destro sulla cartella "Esecuzione automatica" (che si trova tra i programmi di windows), poi--> Apri Cartella Utenti



Dentro a questa cartella ci dovrebbe essere il collegamento a XRGamma

5) cancellare il collegamento a XRGamma
6) copiare il file CaricaLUT.bat dentro alla cartella "Esecuzione automatica"

Bene, ora, dopo ogni avvio di Windows, la LUT della scheda grafica verrà caricata dopo il tempo prefissato

Per capire se la LUT della scheda grafica è caricata correttamente o se è stata resettata, si può utilizzare il programma CalibrationTester.exe

Se la LUT è caricata otterrete una cosa del genere:




Se la LUT non è caricata otterrete questo:



AlbertoM
Go to Top of Page

Michele Volpicella
Advanced Member

1450 Posts

Postato -  17/11/2013 :  21:45:50  Mostra il Profilo  Visita l'Homepage di Michele Volpicella
Volevo solo aggiungere che se la LUT è caricata sull'hardware del monitor e non sulla scheda video apparirà R=G=B per tutti i valori come se non fosse stata caricata, ma il programma è intelligente perchè comunque dice "The gamma curves for display... have been modified"
Ossia funziona anche coi monitor che hanno la LUT hardware.



Stampatore Fine Art
www.slowprint.it
Go to Top of Page

AlbertoM
Moderatore

Italy
4742 Posts

Postato -  17/11/2013 :  21:58:08  Mostra il Profilo  Visita l'Homepage di AlbertoM
Ma nel caso di LUT interna al monitor non ci sono problemi: viene caricata direttamente nel monitor, dal monitor stesso, non dal software sul PC

E la calibrazione HW del monitor, cambia solo quando viene riscritta, cioè quando il monitor viene di nuovo calibrato

Per intenderci, se fai una calibrazione/profilazione HW in windows (con connettore digitale tipo DVI-D o Display port), poi puoi anche prendere un altro PC con Linux, o un Mac con MacOSX, e se ti porti dietro il profilo ICC, impostandolo come profilo di sistema per il monitor, tutto funziona regolarmente

Il problema può nascere quando si usa la LUT della scheda grafica, che è un componente interno al PC: in questo caso è il software che gira nel PC che deve caricarla

AlbertoM
Go to Top of Page

ivanop
Average Member

Italy
161 Posts

Postato -  18/11/2013 :  13:53:21  Mostra il Profilo
A me invece accade una cosa diversa, con win7 e il profilo creato con spectraview II, tutte le sante volte che si riaccende dopo lo screen-saver perde la calibrazione e devo avviare il software (spectraview II) per avere di nuovo il monitor calibrato.
Non ricordo se la stessa cosa accadeva anche con Spectraview profiler.

Ciao,

Ivano.

http://ivanopozzolini.carbonmade.com/
Go to Top of Page

Michele Volpicella
Advanced Member

1450 Posts

Postato -  18/11/2013 :  14:40:01  Mostra il Profilo  Visita l'Homepage di Michele Volpicella
Credo che il problema non sia il caricamento della LUT, ma il caricamento del profilo di sistema. Così si spiegano i problemi sui monitor con LUT in HW.

Inoltre il problema vedo che si verifica dopo la funziona "sleep" e non col screensaver, questo anche sul mio PC che non dà problemi in fase di boot cioè carica la LUT regolarmente.
Comunque non c'è bisogno di avviare tutto il software, basta cliccare sulla LUTloader.exe o comunque si chiami nel vostro software.



Stampatore Fine Art
www.slowprint.it
Go to Top of Page

Michele Volpicella
Advanced Member

1450 Posts

Postato -  18/11/2013 :  19:23:12  Mostra il Profilo  Visita l'Homepage di Michele Volpicella
E..a proposito...ancora un grande grazie ad Alberto per il metodo sviluppato e offerto a tutti noi!



Stampatore Fine Art
www.slowprint.it
Go to Top of Page

a.dalleluche
Junior Member

Italy
20 Posts

Postato -  20/11/2013 :  10:30:00  Mostra il Profilo
Segnalo questo articolo a firma Laszlo Pusztai intitolato "Stop Losing Display Calibration with Windows 7".
Spero possa essere utile alla discussione

Andrea
Go to Top of Page

Michele Volpicella
Advanced Member

1450 Posts

Postato -  20/11/2013 :  14:00:29  Mostra il Profilo  Visita l'Homepage di Michele Volpicella
Secondo me bisogna stare attenti: sulla grande maggioranza dei PC la LUT si carica normalmente senza problemi e su questi io non andrei assolutamente a svegliare il can che dorme ossia a toccare i settings di Windows.
Sui PC con problemi, trovo il metodo di Alberto ancora migliore e più pulito



Stampatore Fine Art
www.slowprint.it
Go to Top of Page

picturesfromthelow
New Member

Italy
14 Posts

Postato -  20/11/2013 :  21:43:42  Mostra il Profilo  Visita l'Homepage di picturesfromthelow
Citazione:
Postato da a.dalleluche

Segnalo questo articolo a firma Laszlo Pusztai intitolato "Stop Losing Display Calibration with Windows 7".
Spero possa essere utile alla discussione

Andrea



Ottima segnalazione Andrea. Uso anch'io questo approccio, è molto comodo e consente di mettere da parte i loaders. Il profilo viene infatti automaticamente caricato da Windows all'avvio del sistema.

Luca
Go to Top of Page

AlbertoM
Moderatore

Italy
4742 Posts

Postato -  20/11/2013 :  22:26:30  Mostra il Profilo  Visita l'Homepage di AlbertoM
In effetti con profili ICC creati da SW X-Rite funziona bene

E funziona come in MacOSX: nell'istante in cui si sceglie un nuovo profilo per il monitor, Windows legge le curve dentro al tag VCGT del nuovo profilo e le carica nella LUT della scheda grafica

Era quello che chiedevo all'inizio

Thanks

AlbertoM

P.S.
Se non ci sono altri commenti sposterei nel Forum's Digest
Go to Top of Page
  Topic Precedente Topic Prossimo Topic  
 Nuovo Topic  Topic Chiuso
 Visualizza per la stampa
Vai a:
PhotoActivity Forum © 2005-2024 PhotoActivity Torna all'inizio della pagina